CiscoNetwork

EİGRP Router Dinamik Yapılandırma Çalışması

Hedefler
⦁ Cisco Router 2621XM aygıtının, dinamik yönlendirme yapılandırmasını gerçekleştireceğiz. Yönlendirme protokolü olarak EIGRP kullanacağız.
⦁ Router alt arayüz yapılandırma özelliğini öğreneceğiz.
Kaynak
⦁ Router yönlendirme bilgisi yönetici tarafından statik bir şekilde yapılandırılabildiği gibi dinamik olarak yönlendirme protokolleri ile de gerçekleştirilebilir. RIP, IGRP, OSPF, EIGRP gibi çeşitli dinamik yönlendirme protokolleri vardır. Her protokolün kendine ait özellikleri vardır. Bu modülümüzde dinamik yönlendirme protokollerinden EIGRP protokolünü öğreneceğiz.
⦁ Eogr2 modüllerinde şuana kadar router aygıtı ile yaptığımız senaryolarda fast ethernet arayüzlerinde tek bir ağ adresi kullandık. Bu senaryomuzda aynı fast ethernet arayüzünde vlan kullanarak 3 farklı ağ adresini router aygıtına tanıtacağız. Bunun için ip yapılandırması yaparken route’ın alt arayüz [router(config-subif)#] modunu kullanacağız.
⦁ Eigrp hem classless hem de classfull olarak çalışabilen bir protokoldür. Varsayılan olarak yapılandırıldığında classfull olarak çalışır. Classless olarak yapılandırmak için, yönlendirme yaparken “no auto summary”özelliği aktif edilmelidir. No auto summmary, update bilgisini komşu router’a subnet mask bilgisi ile birlikte taşır. Fakat burada subnet mask değil, wildcard mask kullanılır. Wildcard mask, subnet mask’ın tam tersi olarak 255’e tamamlayarak elde edilmiş değeridir.
Örn1…/24;
Subnet Mask                 255.255.255.0
Wildcard Mask               0.0.0.255
Örn2…/30;
Subnet Mask                 255.255.255.252
Wildcard Mask               0.0.0.3
Kaynak
⦁ Eigrp yapılandırırken aynı sistemde çalışıldığını gösteren autonomous systemnumber (özerk sistem numarası) kısaca AS olarak ifade edeceğimiz bir numara kullanılır.
⦁ RouterA aygıtı yerel ağında bulunan bilgisayarların ağ geçitleri, bulunduğu vlanların alt arayüz ip adresleridir. Vlan10 için fa0/0.10, Vlan20 için fa0/0.20 ve Vlan30 için fa0/0.30 arayüz ip adresleridir.
⦁ Yönlendirme sonunda, RouterA’nın yerel ağındaki vlanlarında birbiriyle haberleştiği görülür. Panik yok! Şimdilik doğru yoldayız. Farklı ağ adreslerinin router aygıtı kullanarak birbiri ile haberleşmesi olması gereken bir özellik. Eogr modüllerinde ileride göreceğimiz Access Lists (erişim listeleri) ile bu sorunu çözeceğiz.

Adım 1. Senaryodaki router aygıtlarını prototip programınızda kullanın.
Adım 2. CLI arayüzüne girerek Switch0 aygıtında vlan bilgileri ekleyip, arayüzlere atayın.

Switch>enable
Switch#configure terminal
Switch(config)#vlan 10
Switch(config-vlan)#name vlan10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name vlan20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name vlan30
Switch(config-vlan)#exit
Switch(config)#interface FastEthernet0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/2
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/3
Switch(config-if)#switchport access vlan 30
Switch(config)#interface FastEthernet0/24
Switch(config-if)#switchport mode trunk

Adım 3. CLI arayüzüne girerek sırasıyla router aygıtlarının arayüzlerine ip bilgilerini atamak için aşağıdaki kodları uygulayın.

⦁ Router0’a ip bilgileri girin;

 

Router>enable
Router#config terminal
Router(config)#interface FastEthernet0/0
Router(config-if)#no shutdown
Router(config)#int fa 0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip add 172.16.1.1 255.255.255.192
Router(config-subif)#no sh
Router(config-subif)#int fa 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip add 172.16.1.65 255.255.255.192
Router(config-subif)#no sh
Router(config-subif)#int fa 0/0.30
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip add 172.16.1.129 255.255.255.192
Router(config-subif)#no sh
Router(config)#interface Serial0/0
Router(config-if)#ip address 10.0.0.1 255.255.255.252
Router(config-if)#no shutdown

⦁ Router1’a ip bilgileri girin;

Router(config)#interface Serial0/1
Router(config-if)#ip address 10.0.0.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 56000
Router(config)#interface Serial0/0
Router(config-if)#ip address 11.0.0.1 255.255.255.252
Router(config-if)#no shutdown
Router(config)#interface Serial0/2
Router(config-if)#ip address 13.0.0.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 56000

 

⦁ Router2’a ip bilgileri girin;

Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 172.16.2.1 255.255.255.192
Router(config-if)#no shutdown
Router(config)#interface Serial0/0
Router(config-if)#ip address 13.0.0.1 255.255.255.252
Router(config)#interface Serial0/1
Router(config-if)#ip address 12.0.0.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 56000

⦁ Router3’a ip bilgileri girin;

Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 172.16.3.1 255.255.255.192
Router(config-if)#no shutdown
Router(config)#interface Serial0/0
Router(config-if)#ip address 12.0.0.1 255.255.255.252
Router(config-if)#no shutdown
Router(config)#interface Serial0/1
Router(config-if)#ip address 11.0.0.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 56000

Not; Bu ana kadar olan yapılandırma bilgilerini doğrulamak için bilgisayarların kendi ağ geçidi ile haberleşebileceğini görün.


Adım 4. Router aygıtlarına EİGRP yönlendirme bilgilerini girin. AS numarası olarak 100 kullanın.

Router 0’a eigrp yapılandırmasını girin;

Router(config)#router eigrp 100
Router(config-router)#network 172.16.1.0 0.0.0.63
Router(config-router)#network 172.16.1.64 0.0.0.63
Router(config-router)#network 172.16.1.128 0.0.0.63
Router(config-router)#network 10.0.0.0 0.0.0.3
Router(config-router)#no auto-summary

Router 1’e eigrp yapılandırmasını girin;

Router(config-router)#network 10.0.0.0 0.0.0.3
Router(config-router)#network 11.0.0.0 0.0.0.3
Router(config-router)#network 13.0.0.0 0.0.0.3
Router(config-router)#no auto-summary

Router 2’e eigrp yapılandırmasını girin;

Router(config)#router eigrp 100
Router(config-router)#network 12.0.0.0 0.0.0.3
Router(config-router)#network 13.0.0.0 0.0.0.3
Router(config-router)#network 172.16.2.0 0.0.0.63
Router(config-router)#no auto-summary

Router 3’e eigrp yapılandırmasını girin;

Router(config-router)#network 11.0.0.0 0.0.0.3
Router(config-router)#network 12.0.0.0 0.0.0.3
Router(config-router)#network 172.16.3.0 0.0.0.63
Router(config-router)#no auto-summary

Adım 5. Router aygıtlarının yapılandırma bilgisini sunucuya kaydedin.

Örnek; Router0

Router#ping 172.16.3.4
Sending 5, 100-byte ICMP Echos to 172.16.3.4, timeout is 2 seconds:
!!!!!
Router#copy run tftp
Address or name of remote host []? 172.16.3.4
Destination filename [Router-confg]? R0conf
!!
[OK – 860 bytes]…

Sunucuya yapılandırmaları kaydetme işlemini diğer router aygıtları içinde kullanın.

Adım 6. Telnet bağlantısı için Router aygıtlarına telnet ve enable şifreleri girin

Örnek; Router0

Router(config)#enable secret ena123
Router(config)#line vty 0 4
Router(config-line)#password vty123
Router(config-line)#login

Telnet yapılandırmaları işlemini diğer router aygıtları içinde kullanın

Hazır Packet Tracar çalışmasını indirmek için;

EİGRP Router Dinamik Yapılandırma Çalışması.pkt – 86 KB

 

Sonuç;
Yukarıdaki yapılandırmaların tamamı gerçekleştiğinde, bütün bilgisayarların birbiri ile haberleşiyor olması, sunucuya yapılandırmaların yedeklenmiş olması ve router aygıtlarına uzaktan telnet ile erişim yapılıyor olması gerekir.

Bir Yorum

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Başa dön tuşu